<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":4,"applicationTime":181,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81702576-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>ColoradoPrepReport.com  -  Athletes Talk About the 2018 Football Season</title>
<meta content='ColoradoPrepReport.com  -  Athletes Talk About the 2018 Football Season' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-1799fc286a65bd6e618a173906afb32ac0ee785bffdfb588c355d039d145cad1.css" />

<script src="https://cdn.rivals.com/production/assets/application-a2c345a5a66333346e4724c601a0c6601acd1f184e5f23345783d990aa532643.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="+4/AR0pkZBVb3BoHfT4LDS92SALoyRHKhsw/owiRi2BSQ5kvXv90cwXYkG9wqD/VFi3CCfu9YPnJwz4LTvbmzw==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://coloradoprepreport.rivals.com/news/athletes-talk-about-the-2018-football-season-11' property='og:url'>
<meta content='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_thumbnail/lc2tmhr1l5wiqdhjdptm' property='og:image'>
<meta content='Find out what athletes throughout the state are saying about the 2018 football season now!' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-03-17 06:00:00 -0500' property='article:published_time'>
<meta content='2018-03-09 06:47:56 -0600' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "coloradoprepreport.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='coloradoprepreport contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .coloradoprepreport #programming > h1 {
      background-color: #312973 !important; } }
  .coloradoprepreport > header .notification-link .count-container {
    background-color: #312973 !important; }
  .coloradoprepreport > header .wrapper-container {
    background-color: #312973 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .coloradoprepreport > header .wrapper-container {
        border-bottom: 5px solid #c60021 !important; } }
  .coloradoprepreport > header .invalid-email-banner {
    background-color: #312973;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .coloradoprepreport > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .coloradoprepreport > header .invalid-email-banner a:hover {
      color: #c60021; }
  @media screen and (max-width: 767px) {
    .coloradoprepreport > header .mobile-header {
      background-color: #c60021 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .coloradoprepreport > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .coloradoprepreport > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .coloradoprepreport > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .coloradoprepreport > header .nav-row > ul,
    .coloradoprepreport > header .third-nav {
      background-color: white !important; }
    .coloradoprepreport > header .dropdown-toggle > i.fa {
      color: #312973 !important; } }
  .coloradoprepreport > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #312973; }
  
  .site-primary-font-color {
    color: #312973; }
  
  .site-primary-background-color {
    background-color: #312973; }
  
  .site-secondary-font-color {
    color: #c60021; }
  
  .site-secondary-background-color {
    background-color: #c60021; }
  
  :root {
    --outbrain-primary-color: #312973;
    --outbrain-secondary-color: #c60021; }
</style>

<header><nav ng-class='currentUser ? "signed-in" : "signed-out"' ng-controller='NavController' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='toggleContentNav($event)'></a>
      <a alt="Colorado HS Sports" class="school-header" href="//coloradoprepreport.rivals.com"><span class='header-text'>
        ColoradoPrepReport.com
      </span>
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{subscribePath}}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current-user='currentUser'></rv-user-dropdown>
        <rv-forums-info current-user='currentUser' ng-if='currentUser && (isDesktop || isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!isTablet'>
      <ul>
        <li class="home top-nav"><a href="//coloradoprepreport.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;coloradoprepreport&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="currentUser" ng-if="!isTablet &amp;&amp; !isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='isTablet'>
      <ul>
        <li class="home top-nav"><a href="//coloradoprepreport.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;coloradoprepreport&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="currentUser" ng-if="!isTablet &amp;&amp; !isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='showEmailUpdateBanner'>
      <a ng-href='{{userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719648,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Athletes Talk About the 2018 Football Season"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@Rivals' name='twitter:site'>
<meta content='Athletes Talk About the 2018 Football Season' name='twitter:title'>
<meta content='Find out what athletes throughout the state are saying about the 2018 football season now!' name='twitter:description'>
<meta content='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/lc2tmhr1l5wiqdhjdptm' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1902199,"title":"Colorado&#x0027;s Top 150 Football Players in 2020 (31-35)","slug":"colorado-s-top-150-football-players-in-2020-31-35--1","kind":"free","site_id":27,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-17T12:00:00.000-05:00","summary":"Which sophomore football players are rated in the Class of 2020? Find out now from Colorado Prep Report!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-150-football-players-in-2020-31-35--1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902192,"title":"2018 Mountain Girls&#x0027; Lacrosse Conference Preview ","slug":"2018-mountain-girls-lacrosse-conference-preview-1","kind":"free","site_id":27,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-03-16T19:00:00.000-05:00","summary":"Who is the favorite to win the Mountain girls&#x0027; lacrosse conference this spring? Colorado Prep Report dives inside now!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/2018-mountain-girls-lacrosse-conference-preview-1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902184,"title":"2018 3A Tri-Peaks Baseball Conference Preview ","slug":"2018-3a-tri-peaks-baseball-conference-preview","kind":"free","site_id":27,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-03-16T16:30:00.000-05:00","summary":"Who is the favorite to win the 3A Tri-Peaks baseball conference this spring on the diamond?","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/2018-3a-tri-peaks-baseball-conference-preview","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902198,"title":"Colorado&#x0027;s Top 150 Football Players in 2020 (36-40)","slug":"colorado-s-top-150-football-players-in-2020-36-40--1","kind":"free","site_id":27,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-16T14:00:00.000-05:00","summary":"Which sophomore football players are rated in the Class of 2020? Find out now from Colorado Prep Report!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-150-football-players-in-2020-36-40--1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1903493,"title":"Strickland talks 2018 schedule","slug":"strickland-talks-2018-schedule","kind":"premium","site_id":27,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-16T11:30:00.000-05:00","summary":"Pomona linebacker Sanjay Strickland knows that his schedule for the fall is loaded with some of the best teams in the st","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/strickland-talks-2018-schedule","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902179,"title":"Early Track State Predictions - 1A 300 Meter Hurdlers","slug":"early-track-state-predictions-1a-300-meter-hurdlers-1","kind":"free","site_id":27,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-03-16T09:00:00.000-05:00","summary":"Colorado Prep Report previews the athletes who will be in contention for the Class 1A, 300 Meter Hurdlers state champion","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/early-track-state-predictions-1a-300-meter-hurdlers-1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902172,"title":"Colorado&#x0027;s Top 50 Basketball Players in 2021 (1-5)","slug":"colorado-s-top-50-basketball-players-in-2021-1-5--1","kind":"free","site_id":27,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-16T06:30:00.000-05:00","summary":"Which Class of 2021 basketball players are rated numbers 1-25? Find out now from Colorado Prep Report!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-50-basketball-players-in-2021-1-5--1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902182,"title":"2018 5A/4A Denver Prep Baseball Conference Preview ","slug":"2018-5a-4a-denver-prep-baseball-conference-preview-1","kind":"free","site_id":27,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T19:00:00.000-05:00","summary":"Who is the favorite to win the 5A/4A Denver Prep baseball conference this spring on the diamond?","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/2018-5a-4a-denver-prep-baseball-conference-preview-1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902187,"title":"Colorado&#x0027;s Top Third Basemen in 2018","slug":"colorado-s-top-third-basemen-in-2018-9","kind":"free","site_id":27,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T16:30:00.000-05:00","summary":"Colorado Prep Report has updated our list of the top Third Basemen within the Class of 2018 now!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-third-basemen-in-2018-9","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902197,"title":"Colorado&#x0027;s Top 150 Football Players in 2020 (41-45)","slug":"colorado-s-top-150-football-players-in-2020-41-45--1","kind":"free","site_id":27,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T14:00:00.000-05:00","summary":"Which sophomore football players are rated in the Class of 2020? Find out now from Colorado Prep Report!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-150-football-players-in-2020-41-45--1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1903492,"title":"Greiving talks 2018 baseball season","slug":"greiving-talks-2018-baseball-season","kind":"premium","site_id":27,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T11:30:00.000-05:00","summary":"Legend catcher Jake Greiving is excited to see what his team can accomplish this spring with a new coach at the helm. ","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/greiving-talks-2018-baseball-season","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902177,"title":"Early Track State Predictions - 2A 300 Meter Hurdlers","slug":"early-track-state-predictions-2a-300-meter-hurdlers-1","kind":"free","site_id":27,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T09:00:00.000-05:00","summary":"Colorado Prep Report previews the athletes who will be in contention for the Class 2A, 300 Meter Hurdlers state champion","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/early-track-state-predictions-2a-300-meter-hurdlers-1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902171,"title":"Colorado&#x0027;s Top 50 Basketball Players in 2021 (6-10)","slug":"colorado-s-top-50-basketball-players-in-2021-6-10--1","kind":"free","site_id":27,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T06:30:00.000-05:00","summary":"Which Class of 2021 basketball players are rated numbers 1-25? Find out now from Colorado Prep Report!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-50-basketball-players-in-2021-6-10--1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902189,"title":"2018 4A Western Lacrosse Conference Preview ","slug":"2018-4a-western-lacrosse-conference-preview-1","kind":"free","site_id":27,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-03-14T19:00:00.000-05:00","summary":"Who is the favorite to win the 4A Western lacrosse conference this spring? Colorado Prep Report dives inside now!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/2018-4a-western-lacrosse-conference-preview-1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902186,"title":"Colorado&#x0027;s Top Second Basemen in 2018","slug":"colorado-s-top-second-basemen-in-2018-9","kind":"free","site_id":27,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-14T16:30:00.000-05:00","summary":"Colorado Prep Report has updated our list of the top Second Basemen within the Class of 2018 now!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-second-basemen-in-2018-9","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902196,"title":"Colorado&#x0027;s Top 150 Football Players in 2020 (46-50)","slug":"colorado-s-top-150-football-players-in-2020-46-50--1","kind":"free","site_id":27,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-14T14:00:00.000-05:00","summary":"Which sophomore football players are rated in the Class of 2020? Find out now from Colorado Prep Report!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-150-football-players-in-2020-46-50--1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1903491,"title":"Rembao remains a sought-after prospect","slug":"rembao-remains-a-sought-after-prospect","kind":"premium","site_id":27,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-14T11:30:00.000-05:00","summary":"The size and skills of Loveland guard Avery Rembao have helped this standout remain on the radar of a lot of college coa","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/rembao-remains-a-sought-after-prospect","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902176,"title":"Early Track State Predictions - 3A 300 Meter Hurdlers","slug":"early-track-state-predictions-3a-300-meter-hurdlers-1","kind":"free","site_id":27,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-03-14T09:00:00.000-05:00","summary":"Colorado Prep Report previews the athletes who will be in contention for the Class 3A, 300 Meter Hurdlers state champion","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/early-track-state-predictions-3a-300-meter-hurdlers-1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902170,"title":"Colorado&#x0027;s Top 50 Basketball Players in 2021 (11-15)","slug":"colorado-s-top-50-basketball-players-in-2021-11-15--1","kind":"free","site_id":27,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-14T06:30:00.000-05:00","summary":"Which Class of 2021 basketball players are rated numbers 1-25? Find out now from Colorado Prep Report!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-50-basketball-players-in-2021-11-15--1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902181,"title":"2018 5A/4A Continental Baseball Conference Preview ","slug":"2018-5a-4a-continental-baseball-conference-preview-1","kind":"free","site_id":27,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-03-13T19:00:00.000-05:00","summary":"Who is the favorite to win the 5A/4A Continental baseball conference this spring on the diamond?","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/2018-5a-4a-continental-baseball-conference-preview-1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902185,"title":"Colorado&#x0027;s Top First Basemen in 2018","slug":"colorado-s-top-first-basemen-in-2018-9","kind":"free","site_id":27,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-13T16:30:00.000-05:00","summary":"Colorado Prep Report has updated our list of the top First Basemen within the Class of 2018 now!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-first-basemen-in-2018-9","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]},{"id":1902195,"title":"Colorado&#x0027;s Top 150 Football Players in 2020 (51-55)","slug":"colorado-s-top-150-football-players-in-2020-51-55--1","kind":"free","site_id":27,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-13T14:00:00.000-05:00","summary":"Which sophomore football players are rated in the Class of 2020? Find out now from Colorado Prep Report!","deleted":false,"author_name":"Christian James","author_title":"Editor","permalink":"https://coloradoprepreport.rivals.com/news/colorado-s-top-150-football-players-in-2020-51-55--1","site_name":"ColoradoPrepReport.com","type":"Content","associated_links":[]}],nil,27,nil,nil,true); subdomain = &#x0027;coloradoprepreport&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='facebook-ad-container horizontal'>
<div class='mobile-banner' style='display:none; position: relative;'>
<iframe style='display:none;'></iframe>
<script>
  var data = {
    placementid: '223720088042238_252396341841279',
    format: '320x50',
    testmode: false,
    onAdLoaded: function(element) {
      element.style.display = 'block';
    },
    onAdError: function(errorCode, errorMessage) {
    }
  };
  (function(w,l,d,t){var a=t();var b=d.currentScript||(function(){var c=d.getElementsByTagName('script');return c[c.length-1];})();var e=b.parentElement;e.dataset.placementid=data.placementid;var f=function(v){try{return v.document.referrer;}catch(e){}return'';};var g=function(h){var i=h.indexOf('/',h.indexOf('://')+3);if(i===-1){return h;}return h.substring(0,i);};var j=[l.href];var k=false;var m=false;if(w!==w.parent){var n;var o=w;while(o!==n){var h;try{m=m||(o.$sf&&o.$sf.ext);h=o.location.href;}catch(e){k=true;}j.push(h||f(n));n=o;o=o.parent;}}var p=l.ancestorOrigins;if(p){if(p.length>0){data.domain=p[p.length-1];}else{data.domain=g(j[j.length-1]);}}data.url=j[j.length-1];data.channel=g(j[0]);data.width=screen.width;data.height=screen.height;data.pixelratio=w.devicePixelRatio;data.placementindex=w.ADNW&&w.ADNW.Ads?w.ADNW.Ads.length:0;data.crossdomain=k;data.safeframe=!!m;var q={};q.iframe=e.firstElementChild;var r='https://www.facebook.com/audiencenetwork/web/?sdk=5.3';for(var s in data){q[s]=data[s];if(typeof(data[s])!=='function'){r+='&'+s+'='+encodeURIComponent(data[s]);}}q.iframe.src=r;q.tagJsInitTime=a;q.rootElement=e;q.events=[];w.addEventListener('message',function(u){if(u.source!==q.iframe.contentWindow){return;}u.data.receivedTimestamp=t();if(this.sdkEventHandler){this.sdkEventHandler(u.data);}else{this.events.push(u.data);}}.bind(q),false);q.tagJsIframeAppendedTime=t();w.ADNW=w.ADNW||{};w.ADNW.Ads=w.ADNW.Ads||[];w.ADNW.Ads.push(q);w.ADNW.init&&w.ADNW.init(q);})(window,location,document,Date.now||function(){return+new Date;});
</script>
<script async src='https://connect.facebook.net/en_US/fbadnw.js' type='text/javascript'></script>
</div>

</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #312973'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad' ng-if='true'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad' ng-if='true'></div>
<div class='side-rail-meta lrec-ad' ng-if='true'></div>

<rv-homepage-forums ad-referer='https://coloradoprepreport.rivals.com/news/athletes-talk-about-the-2018-football-season-11' background-color='#312973' base-api-url='https://coloradoprepreport.forums.rivals.com/' homepage='false' message-board-url='coloradoprepreport.forums.rivals.com' pub-ad='null' size='size' space-id='2022719648' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://coloradoprepreport.rivals.com/news/athletes-talk-about-the-2018-football-season-11/printable' site-name='ColoradoPrepReport.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-03-17 06:00:00 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1902201/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Athletes Talk About the 2018 Football Season</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Christian James
&bull;
</span>
<span class='type-sm'>ColoradoPrepReport.com</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Editor</span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>Find out what athletes throughout the state are saying about the 2018 football season now!</p><p><a href="https://coloradoprepreport.forums.rivals.com/threads/2018-football-season-quote-board-what-top-players-think-about-the-2018-season.3257/">READ THE FULL ARTICLE BY CLICKING HERE</a></p><p>========================================</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/vzt74sjm3sdwttjfcbjq)'></div>
<img src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/vzt74sjm3sdwttjfcbjq" alt="Vzt74sjm3sdwttjfcbjq" />
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>For the eyes of ColoradoPrepReport.com Subscribers ONLY!<br></p><p>Top Rated Candidates in 2020</p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-sophomore-candidates-part-1-1">Part One</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-sophomore-candidates-part-2-1">Part Two</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-sophomore-candidates-part-3-1">Part Three</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-sophomore-candidates-part-4-1">Part Four</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-sophomore-candidates-part-5-1">Part Five</a></p><p> Top 2020 Football Players</p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-quarterbacks-in-2020-8">Top Quarterbacks</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-running-backs-in-2020-9">Top Running Backs</a></p><p> '18 Preseason Team Rankings</p><p> <a href="https://coloradoprepreport.rivals.com/news/2018-preseason-class-5a-football-rankings-v-3-0-1">Class 5A</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2018-preseason-class-4a-football-rankings-v-3-0-1">Class 4A</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2018-preseason-class-3a-football-rankings-v-3-0-1">Class 3A</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2018-preseason-class-2a-football-rankings-v-3-0-1">Class 2A</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2018-preseason-class-1a-football-rankings-v-3-0-1">Class 1A</a></p><p>2017 All Staters</p><p> <a href="https://coloradoprepreport.rivals.com/news/all-colorado-first-team-all-state-offense-3">All Colorado - First Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2019-first-team-all-state-offense-3">Class of 2019 - First Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2020-first-team-all-state-offense-3">Class of 2020 - First Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/all-colorado-first-team-all-state-defense-3">All Colorado - First Team Defense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2020-first-team-all-state-defense-3">Class of 2020 - First Team Defense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2019-first-team-all-state-defense-2">Class of 2019 - First Team Defense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2020-second-team-all-state-offense-1">Class of 2019 - Second Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2020-second-team-all-state-defense-1">Class of 2020 - Second Team Defense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2019-second-team-all-state-offense-3">Class of 2020 - Second Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2020-third-team-all-state-offense-1">Class of 2020 - Third Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2020-third-team-all-state-defense-1">Class of 2020 - Third Team Defense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2019-second-team-all-state-defense-3">Class of 2019 - Second Team Defense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2019-third-team-all-state-defense-3">Class of 2019 - Third Team Defense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2019-third-team-all-state-offense-3">Class of 2019 - Third Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2021-first-team-all-state-defense-1">Class of 2021 - First Team Defense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2021-first-team-all-state-offense-1">Class of 2021 - First Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-all-colorado-second-team-all-state-offense-1">All Colorado - Second Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-all-colorado-second-team-all-state-defense">All Colorado - Second Team Defense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-all-colorado-third-team-all-state-offense-1">All Colorado - Third Team Offense</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-all-colorado-third-team-all-state-defense-1">All Colorado - Third Team Defense</a></p><p>2017 Awards</p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2020-quarterback-of-the-year-1">2020 Quarterback of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2020-running-back-of-the-year-1">2020 Running Back of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2020-wide-receiver-of-the-year-1">2020 Wide Receiver of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2020-offensive-lineman-of-the-year-1">2020 Offensive Lineman of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2020-kicker-of-the-year-1">2020 Kicker of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2020-punter-of-the-year-1">2020 Punter of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2019-quarterback-of-the-year-1">2019 Quarterback of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2019-running-back-of-the-year-1">2019 Running Back of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2019-wide-receiver-of-the-year-1">2019 Wide Receiver of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2019-offensive-lineman-of-the-year-1">2019 Offensive Lineman of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2019-defensive-lineman-of-the-year-1">2019 Defensive Lineman of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2019-linebacker-of-the-year-1">2019 Linebacker of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2019-defensive-back-of-the-year-1">2019 Defensive Back of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2019-kicker-of-the-year-1">2019 Kicker of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-2019-punter-of-the-year-1">2019 Punter of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-defensive-lineman-of-the-year-1">Defensive Lineman of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-defensive-back-of-the-year-1">Defensive Back of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-punter-of-the-year-1">Punter of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-kicker-of-the-year-1">Kicker of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-senior-of-the-year-1">2018 Player of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-junior-of-the-year-1">2019 Player of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-quarterback-of-the-year-1">Quarterback of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-running-back-of-the-year-1">Running Back of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-wide-receiver-of-the-year-1">Wide Receiver of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-linebacker-of-the-year-1">Linebacker of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-team-of-the-year-1">Team of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-player-of-the-year-1">Player of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-sophomore-of-the-year-1">2020 Player of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-freshman-of-the-year-1">2021 Player of the Year</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/2017-colorado-prep-report-awards-coach-of-the-year-1">Coach of the Year</a></p><p>Top Rated Candidates in 2019</p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-junior-candidates-part-1">Part One</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-junior-candidates-part-2-1">Part Two</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-junior-candidates-part-3-1">Part Three</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-junior-candidates-part-4-1">Part Four</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-10-junior-candidates-part-5-1">Part Five</a></p><p>Player Rankings</p><p> <a href="https://coloradoprepreport.forums.rivals.com/threads/football-all-relevant-articles-are-in-here.4/">Top 50 Players in 2021</a></p><p> <a href="https://coloradoprepreport.forums.rivals.com/threads/football-all-relevant-articles-are-in-here.4/">Top 60 Players in 2020</a></p><p> <a href="https://coloradoprepreport.forums.rivals.com/threads/football-all-relevant-articles-are-in-here.4/">Top 100 Players in 2019</a></p><p> <a href="https://coloradoprepreport.forums.rivals.com/threads/football-all-relevant-articles-are-in-here.4/">Top 185 Players in 2018</a></p><p> Top 2021 Football Players</p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-quarterbacks-in-2021-1">Top Quarterbacks</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-running-backs-in-2021-1">Top Running Backs</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-wide-receivers-in-2021-1">Top Wide Receivers</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-defensive-linemen-in-2021-1"> Top Defensive Linemen</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-linebackers-in-2021-1">Top Linebackers</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-safeties-in-2021-1">Top Safeties</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-defensive-backs-in-2021-1">Top Defensive Backs</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-kickers-in-2021-1">Top Kickers</a></p><p>Top 2019 Football Players</p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-quarterbacks-in-2019-10">Top Quarterbacks</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-running-backs-in-2019-9">Top Running Backs</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-wide-receivers-in-2019-9">Top Wide Receivers</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-tight-ends-in-2019-7">Top Tight Ends</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-offensive-linemen-in-2019-9">Top Offensive Linemen</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-defensive-ends-in-2019-10">Top Defensive Ends</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-defensive-tackles-in-2019-9">Top Defensive Tackles</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-linebackers-in-2019-9">Top Linebackers</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-defensive-backs-in-2019-9">Top Defensive Backs</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-safeties-in-2019-1"> Top Safeties</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-kickers-in-2019-7"> Top Kickers</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-top-punters-in-2019-6">Top Punters</a></p><p>Top Player Databases</p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2018-football-database-8">Class of 2018</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2019-football-database-5">Class of 2019</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/class-of-2020-football-database-1">Class of 2020</a></p><p> Colorado's Most Recruited Players</p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-most-recruited-football-players-in-2018-1-5--1">Players 1-5</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-most-recruited-football-players-in-2018-6-10--1">Players 6-10</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-most-recruited-football-players-in-2018-11-15--1">Players 11-15</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-most-recruited-football-players-in-2018-16-20--1">Players 16-20</a></p><p> <a href="https://coloradoprepreport.rivals.com/news/colorado-s-most-recruited-football-players-in-2018-21-25--1">Players 21-25</a></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://coloradoprepreport.rivals.com/news/athletes-talk-about-the-2018-football-season-11/printable' site-name='ColoradoPrepReport.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":1}]' hide-yahoo-ad='false' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' scoreboard-photos-id='15086' scoreboard-scores-id='15085' site='{"id":27,"legacy_id":1011,"name":"ColoradoPrepReport.com","friendly_name":"Colorado HS Sports","annual_discount":null,"subdomain":"coloradoprepreport","primary_color":"312973","secondary_color":"c60021","font_color":"ffffff","short_name":"coloradoprepreport","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81702576-1"}' twitter-feed='{"id":27,"site_id":27,"handle":null,"list_name":null,"created_at":"2016-02-01T12:24:47.647-06:00","updated_at":"2016-02-01T12:24:47.647-06:00","hashtags":[],"usernames":[],"max_number":null}' yahoo-ad-present></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://coloradoprepreport.rivals.com/news/athletes-talk-about-the-2018-football-season-11/printable' site-name='ColoradoPrepReport.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719648', 'https://coloradoprepreport.rivals.com/news/athletes-talk-about-the-2018-football-season-11');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Athletes Talk About the 2018 Football Season";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer') &amp;&amp; true &amp;&amp; (true)">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://coloradoprepreport.rivals.com' data-widget-id='AR_4' ng-if='true'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='https://n.rivals.com/news/terms-of-service'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719648",
    c7: "https://coloradoprepreport.rivals.com/news/athletes-talk-about-the-2018-football-season-11"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fcoloradoprepreport.rivals.com%2Fnews%2Fathletes-talk-about-the-2018-football-season-11&c5=2022719648&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
